summaryrefslogtreecommitdiffstats
path: root/sca-cpp/trunk/components/webservice/Makefile.am
diff options
context:
space:
mode:
authorjsdelfino <jsdelfino@13f79535-47bb-0310-9956-ffa450edef68>2010-05-30 03:32:37 +0000
committerjsdelfino <jsdelfino@13f79535-47bb-0310-9956-ffa450edef68>2010-05-30 03:32:37 +0000
commit90b55b93704adb3e1fac59d58c2d644d37537bc9 (patch)
treec35f9d4d69789ab45343439044daf9849d1eb4ff /sca-cpp/trunk/components/webservice/Makefile.am
parent3cdc93215b4b0be782060438eec8c20b9c5152ce (diff)
Fix source distribution build scripts, add missing files to the dist targets.
git-svn-id: http://svn.us.apache.org/repos/asf/tuscany@949466 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to '')
-rw-r--r--sca-cpp/trunk/components/webservice/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/sca-cpp/trunk/components/webservice/Makefile.am b/sca-cpp/trunk/components/webservice/Makefile.am
index accc098b79..4d659db44e 100644
--- a/sca-cpp/trunk/components/webservice/Makefile.am
+++ b/sca-cpp/trunk/components/webservice/Makefile.am
@@ -19,11 +19,13 @@ if WANT_WEBSERVICE
INCLUDES = -I${AXIS2C_INCLUDE}
-comp_SCRIPTS = axis2-conf
+dist_comp_SCRIPTS = axis2-conf
compdir=$(prefix)/components/webservice
comp_DATA = axis2c.prefix axis2.xml services.xml module.xml
+EXTRA_DIST = webservice.composite axis2.xml services.xml module.xml *.scm
+
axis2c.prefix: $(top_builddir)/config.status
echo ${AXIS2C_PREFIX} >axis2c.prefix
@@ -59,6 +61,7 @@ axis2_test_LDFLAGS = -lxml2 -L${AXIS2C_LIB} -R${AXIS2C_LIB} -laxis2_engine -laxi
client_test_SOURCES = client-test.cpp
client_test_LDFLAGS = -lxml2 -lcurl -lmozjs -L${AXIS2C_LIB} -R${AXIS2C_LIB} -laxis2_engine -laxis2_axiom -laxutil
+dist_noinst_SCRIPTS = echo-test server-test
noinst_PROGRAMS = axiom-test axis2-test client-test
TESTS = axiom-test echo-test server-test