summaryrefslogtreecommitdiffstats
path: root/sca-cpp/trunk/components/sqldb/Makefile.am
diff options
context:
space:
mode:
authorjsdelfino <jsdelfino@13f79535-47bb-0310-9956-ffa450edef68>2010-05-29 19:44:35 +0000
committerjsdelfino <jsdelfino@13f79535-47bb-0310-9956-ffa450edef68>2010-05-29 19:44:35 +0000
commite5a49fff24c79431782da107185431b7835ef492 (patch)
tree8bb6ca1aaad4fed82443dcb7d420533c31eb3eb4 /sca-cpp/trunk/components/sqldb/Makefile.am
parent7eef73b80c5f6c4f34f57cc48a46383689acecca (diff)
Fix distribution build, add missing files and samples and fix path to libraries. GCC 4.5 is used if available but not installed automatically.
git-svn-id: http://svn.us.apache.org/repos/asf/tuscany@949435 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to '')
-rw-r--r--sca-cpp/trunk/components/sqldb/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/sca-cpp/trunk/components/sqldb/Makefile.am b/sca-cpp/trunk/components/sqldb/Makefile.am
index d474dafb25..8abf252d92 100644
--- a/sca-cpp/trunk/components/sqldb/Makefile.am
+++ b/sca-cpp/trunk/components/sqldb/Makefile.am
@@ -19,7 +19,7 @@ if WANT_SQLDB
INCLUDES = -I${PGSQL_INCLUDE}
-comp_SCRIPTS = pgsql-start pgsql-stop
+comp_SCRIPTS = pgsql-start pgsql-stop pgsql
compdir=$(prefix)/components/sqldb
comp_DATA = pgsql.prefix
@@ -27,9 +27,12 @@ pgsql.prefix: $(top_builddir)/config.status
echo ${PGSQL_PREFIX} >pgsql.prefix
comp_LTLIBRARIES = libsqldb.la
+noinst_DATA = libsqldb.so
libsqldb_la_SOURCES = sqldb.cpp
libsqldb_la_LDFLAGS = -L${PGSQL_LIB} -R${PGSQL_LIB} -lpq
+libsqldb.so:
+ ln -s .libs/libsqldb.so
pgsql_test_SOURCES = pgsql-test.cpp
pgsql_test_LDFLAGS = -L${PGSQL_LIB} -R${PGSQL_LIB} -lpq