summaryrefslogtreecommitdiffstats
path: root/sca-cpp/trunk/components/queue/Makefile.am
diff options
context:
space:
mode:
authorjsdelfino <jsdelfino@13f79535-47bb-0310-9956-ffa450edef68>2010-05-30 03:32:37 +0000
committerjsdelfino <jsdelfino@13f79535-47bb-0310-9956-ffa450edef68>2010-05-30 03:32:37 +0000
commit90b55b93704adb3e1fac59d58c2d644d37537bc9 (patch)
treec35f9d4d69789ab45343439044daf9849d1eb4ff /sca-cpp/trunk/components/queue/Makefile.am
parent3cdc93215b4b0be782060438eec8c20b9c5152ce (diff)
Fix source distribution build scripts, add missing files to the dist targets.
git-svn-id: http://svn.us.apache.org/repos/asf/tuscany@949466 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to '')
-rw-r--r--sca-cpp/trunk/components/queue/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/sca-cpp/trunk/components/queue/Makefile.am b/sca-cpp/trunk/components/queue/Makefile.am
index 2a6f83d5ce..cbd81a5993 100644
--- a/sca-cpp/trunk/components/queue/Makefile.am
+++ b/sca-cpp/trunk/components/queue/Makefile.am
@@ -19,13 +19,15 @@ if WANT_QUEUE
INCLUDES = -I${QPIDC_INCLUDE}
-comp_SCRIPTS = qpidd-start qpidd-stop
+dist_comp_SCRIPTS = qpidd-start qpidd-stop
compdir=$(prefix)/components/queue
comp_DATA = qpidc.prefix
qpidc.prefix: $(top_builddir)/config.status
echo ${QPIDC_PREFIX} >qpidc.prefix
+EXTRA_DIST = queue.composite *.scm
+
comp_LTLIBRARIES = libqueue-sender.la libqueue-listener.la
noinst_DATA = libqueue-sender.so libqueue-listener.so
@@ -45,6 +47,7 @@ qpid_test_LDFLAGS = -L${QPIDC_LIB} -R${QPIDC_LIB} -lqpidclient -lqpidcommon
client_test_SOURCES = client-test.cpp
client_test_LDFLAGS = -lxml2 -lcurl -lmozjs -L${QPIDC_LIB} -R${QPIDC_LIB} -lqpidclient -lqpidcommon
+dist_noinst_SCRIPTS = send-test server-test
noinst_PROGRAMS = qpid-test client-test
TESTS = send-test server-test