summaryrefslogtreecommitdiffstats
path: root/sca-cpp/trunk/components/queue/Makefile.am
diff options
context:
space:
mode:
authorjsdelfino <jsdelfino@13f79535-47bb-0310-9956-ffa450edef68>2010-02-01 07:57:32 +0000
committerjsdelfino <jsdelfino@13f79535-47bb-0310-9956-ffa450edef68>2010-02-01 07:57:32 +0000
commit80f6823cacf6f018cbe0d86198afa23be71f991f (patch)
tree64181f34f79e158e945c8e3aba7da2d3514f0bc7 /sca-cpp/trunk/components/queue/Makefile.am
parent8c5172b8ab407b79db53ce46271d72d8a3f9c19f (diff)
Added build configuration and dependencies for chat and queue components.
git-svn-id: http://svn.us.apache.org/repos/asf/tuscany@905203 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to '')
-rw-r--r--sca-cpp/trunk/components/queue/Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/sca-cpp/trunk/components/queue/Makefile.am b/sca-cpp/trunk/components/queue/Makefile.am
index b2a9b3819e..cee3ce7820 100644
--- a/sca-cpp/trunk/components/queue/Makefile.am
+++ b/sca-cpp/trunk/components/queue/Makefile.am
@@ -17,4 +17,15 @@
if WANT_QUEUE
+INCLUDES = -I${QPIDC_INCLUDE}
+
+compdir=$(prefix)/components/queue
+comp_LTLIBRARIES = libqueue-sender.la libqueue-listener.la
+
+libqueue_sender_la_SOURCES = queue-sender.cpp
+libqueue_sender_la_LDFLAGS = -L${QPIDC_LIB} -R${QPIDC_LIB} -lqpidclient
+
+libqueue_listener_la_SOURCES = queue-listener.cpp
+libqueue_listener_la_LDFLAGS = -L${QPIDC_LIB} -R${QPIDC_LIB} -lqpidclient
+
endif