summaryrefslogtreecommitdiffstats
path: root/sca-cpp/trunk/components/cache/Makefile.am
diff options
context:
space:
mode:
authorjsdelfino <jsdelfino@13f79535-47bb-0310-9956-ffa450edef68>2009-11-30 08:36:59 +0000
committerjsdelfino <jsdelfino@13f79535-47bb-0310-9956-ffa450edef68>2009-11-30 08:36:59 +0000
commit0b9d0491fe4fb19c8d2f269c805d0b022ca157f4 (patch)
tree4c7a7cc35ad96f6a412eca9a1089ed0120ad2039 /sca-cpp/trunk/components/cache/Makefile.am
parentff124040623879bc48a0ba5cf06a841642adef53 (diff)
More build improvements, added a configure option to turn on debugging and profiling, fixed compile and link options to support multithreading where applicable, moved non-building tools to contrib, and adjusted the top readmes and build instructions.
git-svn-id: http://svn.us.apache.org/repos/asf/tuscany@885350 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'sca-cpp/trunk/components/cache/Makefile.am')
-rw-r--r--sca-cpp/trunk/components/cache/Makefile.am13
1 files changed, 8 insertions, 5 deletions
diff --git a/sca-cpp/trunk/components/cache/Makefile.am b/sca-cpp/trunk/components/cache/Makefile.am
index d1a589bb52..22410eb611 100644
--- a/sca-cpp/trunk/components/cache/Makefile.am
+++ b/sca-cpp/trunk/components/cache/Makefile.am
@@ -15,17 +15,20 @@
# specific language governing permissions and limitations
# under the License.
-noinst_PROGRAMS = mcache-test
+noinst_PROGRAMS = mcache-test mcache-client-test
-INCLUDES = -I. -I$(top_builddir)/kernel -I${LIBXML2_INCLUDE} -I${APR_INCLUDE}
+INCLUDES = -I. -I$(top_builddir)/kernel -I${LIBXML2_INCLUDE} -I${APR_INCLUDE} -I${JS_INCLUDE} -I${CURL_INCLUDE}
compdir=$(prefix)/components/cache
comp_LTLIBRARIES = libmcache.la
libmcache_la_SOURCES = mcache.cpp
-libmcache_la_LIBADD = -lpthread -L${APR_LIB} -lapr-1 -laprutil-1
+libmcache_la_LIBADD = -L${APR_LIB} -lapr-1 -laprutil-1
mcache_test_SOURCES = mcache-test.cpp
-mcache_test_LDADD = -lpthread -L${LIBXML2_LIB} -lxml2 -L${APR_LIB} -lapr-1 -laprutil-1
+mcache_test_LDADD = -L${LIBXML2_LIB} -lxml2 -L${APR_LIB} -lapr-1 -laprutil-1
-TESTS = memcached-test
+mcache_client_test_SOURCES = mcache-client-test.cpp
+mcache_client_test_LDADD = -L${LIBXML2_LIB} -lxml2 -L${APR_LIB} -lapr-1 -laprutil-1 -L${CURL_LIB} -lcurl -L${JS_LIB} -lmozjs
+
+TESTS = memcached-test memcached-server-test