summaryrefslogtreecommitdiffstats
path: root/sca-cpp/branches/cpp-contrib/contrib/runtime/extensions/cpp/tools/scagen/Makefile.am
diff options
context:
space:
mode:
authorjsdelfino <jsdelfino@13f79535-47bb-0310-9956-ffa450edef68>2010-02-28 19:40:06 +0000
committerjsdelfino <jsdelfino@13f79535-47bb-0310-9956-ffa450edef68>2010-02-28 19:40:06 +0000
commite982b4ef38fd043c15e89bdd60763b10434a087e (patch)
tree6b9d9c3fc9aff22edb0f137040164c1cbf2359af /sca-cpp/branches/cpp-contrib/contrib/runtime/extensions/cpp/tools/scagen/Makefile.am
parent64e2486555a0a14f7d9690c2fc62c30bde803a91 (diff)
Moving old inactive code to a branch as it's confusing code assist, searches and indexing in trunk.
git-svn-id: http://svn.us.apache.org/repos/asf/tuscany@917273 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to '')
-rw-r--r--sca-cpp/branches/cpp-contrib/contrib/runtime/extensions/cpp/tools/scagen/Makefile.am35
1 files changed, 35 insertions, 0 deletions
diff --git a/sca-cpp/branches/cpp-contrib/contrib/runtime/extensions/cpp/tools/scagen/Makefile.am b/sca-cpp/branches/cpp-contrib/contrib/runtime/extensions/cpp/tools/scagen/Makefile.am
new file mode 100644
index 0000000000..59b4d2095f
--- /dev/null
+++ b/sca-cpp/branches/cpp-contrib/contrib/runtime/extensions/cpp/tools/scagen/Makefile.am
@@ -0,0 +1,35 @@
+# Licensed to the Apache Software Foundation (ASF) under one
+# or more contributor license agreements. See the NOTICE file
+# distributed with this work for additional information
+# regarding copyright ownership. The ASF licenses this file
+# to you under the Apache License, Version 2.0 (the
+# "License"); you may not use this file except in compliance
+# with the License. You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing,
+# software distributed under the License is distributed on an
+# "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY
+# KIND, either express or implied. See the License for the
+# specific language governing permissions and limitations
+# under the License.
+
+SUBDIRS =
+
+BUILT_SOURCES = scagen_build
+EXTRA_DIST = build.xml scagen.sh src META-INF
+bin_SCRIPTS = scagen.sh
+
+scagen_build:
+ ant
+ touch scagen_build
+
+clean:
+ rm -rf build
+ rm -rf docs
+ rm -f scagen_build
+
+install-exec-hook:
+ cp build/scagen.jar $(bindir)
+