summaryrefslogtreecommitdiffstats
path: root/cpp/sca/samples/store/Makefile.am
diff options
context:
space:
mode:
authorjsdelfino <jsdelfino@13f79535-47bb-0310-9956-ffa450edef68>2009-10-03 21:50:33 +0000
committerjsdelfino <jsdelfino@13f79535-47bb-0310-9956-ffa450edef68>2009-10-03 21:50:33 +0000
commitb2b06bd2780dc40f666201d095c388313364b37a (patch)
tree1186e75dd637a02e567f91a1c5d7014a2bca7a95 /cpp/sca/samples/store/Makefile.am
parent95cb8fb517576b3357ecdf27a30c29b1365c5cf5 (diff)
Refactored store tests and moved them under test/. Simplified the script evaluation logic a little, added an apply procedure and support for variable lists of args. Added a test case that assembles the store app using a script.
git-svn-id: http://svn.us.apache.org/repos/asf/tuscany@821425 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to '')
-rw-r--r--cpp/sca/test/Makefile.am (renamed from cpp/sca/samples/store/Makefile.am)10
1 files changed, 1 insertions, 9 deletions
diff --git a/cpp/sca/samples/store/Makefile.am b/cpp/sca/test/Makefile.am
index 05a0e4482a..4a20e27139 100644
--- a/cpp/sca/samples/store/Makefile.am
+++ b/cpp/sca/test/Makefile.am
@@ -15,13 +15,5 @@
# specific language governing permissions and limitations
# under the License.
-store_PROGRAMS = store-test
-storedir=$(prefix)/store/deploy
+SUBDIRS = store-object store-function store-script
-store_test_SOURCES = store-test.cpp
-
-INCLUDES = -I. -I${TUSCANY_SCACPP}/include
-store_test_LDADD = -L${TUSCANY_SCACPP}/lib -ltuscany_sca -L${LIBXML2_LIB} -lxml2
-
-EXTRA_DIST = *.composite
-store_DATA = *.composite