summaryrefslogtreecommitdiffstats
path: root/cpp/sca/samples/configure.ac
diff options
context:
space:
mode:
authorjsdelfino <jsdelfino@13f79535-47bb-0310-9956-ffa450edef68>2009-09-06 00:14:47 +0000
committerjsdelfino <jsdelfino@13f79535-47bb-0310-9956-ffa450edef68>2009-09-06 00:14:47 +0000
commit3738a675ec636a23e3292bd75818803a672706c5 (patch)
treec5ed189f511f7b78aae7fc98000ed32685d67c4d /cpp/sca/samples/configure.ac
parentf6fe45a18af190404294956afbb0a782cf02e940 (diff)
More fixes to the autoconf build. Fixed Samples and Distros builds.
git-svn-id: http://svn.us.apache.org/repos/asf/tuscany@811730 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to '')
-rw-r--r--cpp/sca/samples/configure.ac15
1 files changed, 14 insertions, 1 deletions
diff --git a/cpp/sca/samples/configure.ac b/cpp/sca/samples/configure.ac
index 6ebc4acb6d..2131e8dcc8 100644
--- a/cpp/sca/samples/configure.ac
+++ b/cpp/sca/samples/configure.ac
@@ -18,7 +18,7 @@
dnl run autogen.sh to generate the configure script.
AC_PREREQ(2.59)
-AC_INIT(tuscany_sca_samples, 1.0-incubator-M3)
+AC_INIT(tuscany-sca-samples, 1.0-M3)
AC_CANONICAL_SYSTEM
AM_CONFIG_HEADER(config.h)
AM_INIT_AUTOMAKE(AC_PACKAGE_NAME, AC_PACKAGE_VERSION)
@@ -66,6 +66,19 @@ AC_FUNC_STAT
AC_FUNC_VPRINTF
AC_CHECK_FUNCS([getcwd putenv strdup])
+# Configure TUSCANY_SCACPP and TUSCANY_SDOCPP
+TUSCANY_SCACPP=`echo "$TUSCANY_SCACPP"`
+if test "x$TUSCANY_SCACPP" = "x"; then
+ SCAPWD=`pwd`
+ AC_SUBST([TUSCANY_SCACPP], ["$SCAPWD/.."])
+fi
+
+TUSCANY_SDOCPP=`echo "$TUSCANY_SDOCPP"`
+if test "x$TUSCANY_SDOCPP" = "x"; then
+ SCAPWD=`pwd`
+ AC_SUBST([TUSCANY_SDOCPP], ["$SCAPWD/../../sdo/deploy"])
+fi
+
AC_MSG_CHECKING(whether to build all samples)
AC_ARG_ENABLE(all-samples, [AS_HELP_STRING([--enable-all-samples],[build all samples [default=no]])],
[ case "${enableval}" in