summaryrefslogtreecommitdiffstats
path: root/cpp/sca/samples/configure.ac
diff options
context:
space:
mode:
authorjsdelfino <jsdelfino@13f79535-47bb-0310-9956-ffa450edef68>2009-09-14 05:55:17 +0000
committerjsdelfino <jsdelfino@13f79535-47bb-0310-9956-ffa450edef68>2009-09-14 05:55:17 +0000
commit1f1af3587a9a9f666c3faa76a651553c292ebc40 (patch)
tree4dc362816031da471cc3bf4bb3fb52f31d3903d4 /cpp/sca/samples/configure.ac
parent67618c80483e01793351b20cbbbc5a56a6a8f016 (diff)
Adjusted makefiles and configure.ac to start to build the store sample.
git-svn-id: http://svn.us.apache.org/repos/asf/tuscany@814482 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to '')
-rw-r--r--cpp/sca/samples/configure.ac15
1 files changed, 15 insertions, 0 deletions
diff --git a/cpp/sca/samples/configure.ac b/cpp/sca/samples/configure.ac
index 2131e8dcc8..e03204ba66 100644
--- a/cpp/sca/samples/configure.ac
+++ b/cpp/sca/samples/configure.ac
@@ -79,6 +79,20 @@ if test "x$TUSCANY_SDOCPP" = "x"; then
AC_SUBST([TUSCANY_SDOCPP], ["$SCAPWD/../../sdo/deploy"])
fi
+# Configure LIBXML2_INCLUDE and LIBXML2_LIB
+LIBXML2_INCLUDE=`echo "$LIBXML2_INCLUDE"`
+if test "x$LIBXML2_INCLUDE" = "x"; then
+ AC_SUBST([LIBXML2_INCLUDE], ["/usr/include/libxml2"])
+fi
+
+LIBXML2_LIB=`echo "$LIBXML2_LIB"`
+if test "x$LIBXML2_LIB" = "x"; then
+ AC_SUBST([LIBXML2_LIB], ["/usr/lib"])
+fi
+
+# Configure GCC C++ compile options
+AC_SUBST([CXXFLAGS], ["$(CXXFLAGS) -D_DEBUG -O0 -g3 -Wall -std=c++0x -fmessage-length=0"])
+
AC_MSG_CHECKING(whether to build all samples)
AC_ARG_ENABLE(all-samples, [AS_HELP_STRING([--enable-all-samples],[build all samples [default=no]])],
[ case "${enableval}" in
@@ -148,6 +162,7 @@ AC_ARG_ENABLE(ruby, [AS_HELP_STRING([--enable-ruby],[build Ruby samples [default
AM_CONDITIONAL([WANT_RUBY_SAMPLES], [test x$want_ruby_samples = xtrue])
AC_CONFIG_FILES([Makefile
+ store/Makefile
AlertAggregator/Makefile
AlertAggregator/sample.alerter/Makefile
AlertAggregator/sample.display/Makefile