summaryrefslogtreecommitdiffstats
path: root/cpp/sca/runtime/extensions/php/src/Makefile.am
diff options
context:
space:
mode:
authorjsdelfino <jsdelfino@13f79535-47bb-0310-9956-ffa450edef68>2009-09-06 01:43:25 +0000
committerjsdelfino <jsdelfino@13f79535-47bb-0310-9956-ffa450edef68>2009-09-06 01:43:25 +0000
commitb536cddde8a421788543a8290b944c6271e63b3f (patch)
treea20cdf7b910b45271ed61f41f9f7fcc92ab402f6 /cpp/sca/runtime/extensions/php/src/Makefile.am
parent30e4f86386d9cc642952228105f023bef2fc1cd8 (diff)
Moved configuration of CXXFLAGS compile options to configure.ac script to make them consistent across the project. Increased warning level and enabled support for debug and profiling.
git-svn-id: http://svn.us.apache.org/repos/asf/tuscany@811742 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to '')
-rw-r--r--cpp/sca/runtime/extensions/php/src/Makefile.am4
1 files changed, 1 insertions, 3 deletions
diff --git a/cpp/sca/runtime/extensions/php/src/Makefile.am b/cpp/sca/runtime/extensions/php/src/Makefile.am
index b3622779e6..d0b04262f5 100644
--- a/cpp/sca/runtime/extensions/php/src/Makefile.am
+++ b/cpp/sca/runtime/extensions/php/src/Makefile.am
@@ -48,12 +48,10 @@ INCLUDES = -I${TUSCANY_SCACPP}/include \
-I${PHP_INCLUDE}/sapi/embed \
-I${PHP_SCA_SDO_INCLUDE}
-AM_CPPFLAGS = $(CPPFLAGS) -D_DEBUG
-
moduledir=$(prefix)/module
extension = libtuscany_sca_php$(libsuffix)
install-exec-hook:
test -z $(moduledir) || $(mkdir_p) $(moduledir);
-rm -f $(moduledir)/$(extension)
- $(LN_S) $(libdir)/$(extension) $(moduledir)/$(extension) \ No newline at end of file
+ $(LN_S) $(libdir)/$(extension) $(moduledir)/$(extension)