summaryrefslogtreecommitdiffstats
path: root/cpp/sca/modules/cache/Makefile.am
diff options
context:
space:
mode:
authorjsdelfino <jsdelfino@13f79535-47bb-0310-9956-ffa450edef68>2009-11-16 06:01:30 +0000
committerjsdelfino <jsdelfino@13f79535-47bb-0310-9956-ffa450edef68>2009-11-16 06:01:30 +0000
commit4109b6c23b5169463bd493347dddb1ab58aa0860 (patch)
tree9aeee1019d6e7e1b9d92b33e12aadf8811fcebce /cpp/sca/modules/cache/Makefile.am
parentec5f59dac8d5eca3504ec5fe205dcb7d8fd382a6 (diff)
Added SCDL parsing functions. Refactored cache support with disk-cached functions that can be used to cache SCDL files. Minor makefile updates to get build and ctags working on Ubuntu 9.10.
git-svn-id: http://svn.us.apache.org/repos/asf/tuscany@880599 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to '')
-rw-r--r--cpp/sca/modules/cache/Makefile.am13
1 files changed, 9 insertions, 4 deletions
diff --git a/cpp/sca/modules/cache/Makefile.am b/cpp/sca/modules/cache/Makefile.am
index 581b8b6682..0597e91804 100644
--- a/cpp/sca/modules/cache/Makefile.am
+++ b/cpp/sca/modules/cache/Makefile.am
@@ -15,12 +15,17 @@
# specific language governing permissions and limitations
# under the License.
-noinst_PROGRAMS = cache-test
+noinst_PROGRAMS = diskcache-test memcache-test
+
+nobase_include_HEADERS = *.hpp
INCLUDES = -I. -I$(top_builddir)/kernel -I${LIBXML2_INCLUDE} -I${APR_INCLUDE}
-cache_test_SOURCES = cache-test.cpp
-cache_test_LDADD = -lpthread -L${LIBXML2_LIB} -lxml2 -L${APR_LIB} -lapr-1 -laprutil-1
+diskcache_test_SOURCES = diskcache-test.cpp
+diskcache_test_LDADD = -lpthread -L${LIBXML2_LIB} -lxml2 -L${APR_LIB} -lapr-1 -laprutil-1
+
+memcache_test_SOURCES = memcache-test.cpp
+memcache_test_LDADD = -lpthread -L${LIBXML2_LIB} -lxml2 -L${APR_LIB} -lapr-1 -laprutil-1
-TESTS = memcached-test
+TESTS = memcached-test diskcached-test