summaryrefslogtreecommitdiffstats
path: root/cpp/sca/configure.ac
diff options
context:
space:
mode:
authorjsdelfino <jsdelfino@13f79535-47bb-0310-9956-ffa450edef68>2009-09-06 01:43:25 +0000
committerjsdelfino <jsdelfino@13f79535-47bb-0310-9956-ffa450edef68>2009-09-06 01:43:25 +0000
commitb536cddde8a421788543a8290b944c6271e63b3f (patch)
treea20cdf7b910b45271ed61f41f9f7fcc92ab402f6 /cpp/sca/configure.ac
parent30e4f86386d9cc642952228105f023bef2fc1cd8 (diff)
Moved configuration of CXXFLAGS compile options to configure.ac script to make them consistent across the project. Increased warning level and enabled support for debug and profiling.
git-svn-id: http://svn.us.apache.org/repos/asf/tuscany@811742 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to '')
-rw-r--r--cpp/sca/configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/cpp/sca/configure.ac b/cpp/sca/configure.ac
index 476b531087..4daeef1985 100644
--- a/cpp/sca/configure.ac
+++ b/cpp/sca/configure.ac
@@ -91,6 +91,9 @@ if test "x$LIBXML2_LIB" = "x"; then
AC_SUBST([LIBXML2_LIB], ["/usr/lib"])
fi
+# Configure GCC C++ compile options
+AC_SUBST([CXXFLAGS], ["$(CXXFLAGS) -D_DEBUG -O0 -g3 -Wall -std=c++0x -fmessage-length=0"])
+
AC_MSG_CHECKING(whether to build all component type and binding extensions)
AC_ARG_ENABLE(all-extensions, [AS_HELP_STRING([--enable-all-extensions],[build all runtime extensions [default=no]])],
[ case "${enableval}" in