summaryrefslogtreecommitdiffstats
path: root/sca-cpp/trunk/configure.ac
diff options
context:
space:
mode:
authorjsdelfino <jsdelfino@13f79535-47bb-0310-9956-ffa450edef68>2013-08-26 05:18:15 +0000
committerjsdelfino <jsdelfino@13f79535-47bb-0310-9956-ffa450edef68>2013-08-26 05:18:15 +0000
commit91c4354f61b14cbdab6a2f1922f4ffca23acaf22 (patch)
tree4bd4d3259e53cd24930c27a40323acce848b40c8 /sca-cpp/trunk/configure.ac
parent8603a54631cbc4201ee4078de1b2bf54bdd4603d (diff)
Fix build errors with latest GCC and CLang compilers.
git-svn-id: http://svn.us.apache.org/repos/asf/tuscany@1517422 13f79535-47bb-0310-9956-ffa450edef68
Diffstat (limited to 'sca-cpp/trunk/configure.ac')
-rw-r--r--sca-cpp/trunk/configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/sca-cpp/trunk/configure.ac b/sca-cpp/trunk/configure.ac
index b0992a58b1..041c83a384 100644
--- a/sca-cpp/trunk/configure.ac
+++ b/sca-cpp/trunk/configure.ac
@@ -121,7 +121,7 @@ if test "${want_maintainer_mode}" = "true"; then
if test "${cxxtype}" = "clang"; then
cxxflags="${cxxflags} -O1 -stdlib=libc++ -Qunused-arguments -Wno-return-type-c-linkage"
else
- cxxflags="${cxxflags} -O2 -Wlogical-op -Wconversion"
+ cxxflags="${cxxflags} -O2 -Wlogical-op -Wconversion -Wno-attributes"
fi
AM_CONDITIONAL([WANT_MAINTAINER_MODE], true)
AC_DEFINE([WANT_MAINTAINER_MODE], 1, [compile with debugging and compile-time warnings])